Error: "[NG14632] Send request failed on iMSL" appears when opening print records in NuGenesis SDMS - WKB193099
Article number: 193099
SYMPTOMS
- The following error message appears when clicking on print records in SDMS WebVision:
- [NG14632] Send request failed on iMSL
- The NuGenesis Restore app crashes with an unhandled exception
- Other machines in the same domain have the same problem, but machines which are in the same domain as the SDMS web server do not have this problem
- The client machine can resolve the SDMS web server's full domain name (example: sdmsweb1.domain.com) but it cannot resolve the web server's hostname (sdmsweb1, in this example)
ENVIRONMENT
- NuGenesis 9 SDMS
- NuGenesis 8 SDMS
CAUSE
The client machine is unable to resolve the web server's host name to the correct IP address due to the use of a different DNS server.
FIX or WORKAROUND
There are several different means of resolving this issue
- Configure an entry in the C:\Windows\system32\drivers\etc\hosts file on the client machine(s) with the correct IP address for the SDMS web server;
- Configure the IP protocol stack in the client machines to append the SDMS server's domain as a suffix in DNS search queries;
- Modify the WebVision configuration files to include a fully-qualified domain name in the entry for the local server:
- Legacy WebVision example:
- File: Drive:\Program Files (x86)\Waters\apache-tomcat-9.0.X\webapps\WebVision\ngvision\WebVision.ini
- Contents: local='localhost',1,12020,100,100,'C:\\Program Files (x86)\\Waters\\NGSDMS\\Application Server\\','','','','NuGenesis RPC Service','sdmsweb1.domain.com',2500
- New WebVision example:
- File: Drive:\Program Files (x86)\Waters\NGSDMS\Application Server\Vision\SdmsProjects\appsettings.json
- Contents: "RpcService: {
"HostName": "servername"
"RpcServiceName": "NuGenesis RPC Service"
"Port": "2500"
}
- Legacy WebVision example:
ADDITIONAL INFORMATION
id193099, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG