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Error when trying to open NuGenesis LMS document: "Could not find file 'C:\Users..." - WKB190713

Article number: 190713

SYMPTOMS

  • The following error appears when trying to open LMS document: "Could not find file 'C:\Users\UserName\AppData\Roaming\Waters\NuGenesis LMS\version\ExpCache\..."
  • The error is reproducible with a given document on any NuGenesis LMS client

ENVIRONMENT

  • NuGenesis 9.0.2

CAUSE

The root cause is not yet known. CRI-3191 was raised with the development team to investigate.

FIX or WORKAROUND

  1. Fixes:
    • For customers on NuGenesis 9.0.x: Upgrade to NuGenesis LMS 9.0.2 Hotfix 3
    • For customers on NuGenesis 9.1: Upgrade to NuGenesis LMS 9.1 Hotfix 2
    • This issue is also fixed in NuGenesis 9.2 / Empower LMS 1.0
  2. Workarounds (IMPORTANT - see Additional Information Below):
    • Marking the affected document sections as logically deleted has proven successful in allowing LMS to open the documents. This process currently must be done with a direct SQL update statement to the database. Currently, only Waters personnel should make such updates and only after consultation with GSS.
      1. The error message provides two key pieces of information for the update statement.  For example, given this file path:
        • C:\Users\username\AppData\Roaming\Waters\NuGenesis LMS\9.0.2.1\ExpCache\2021000000474\9d8fbc88-1478-46fd-8aee-6d89d0cb7e72\VERSIONS\1\2216_0
      2. "2021000000474" is the document order ID and "9d8fbc88-1478-46fd-8aee-6d89d0cb7e72" is the section GUID
      3. Paste the order ID and the section GUID into the following SQL query template:
        • UPDATE elnprod.mo_method SET deletion = 'Y' WHERE orderid IN ('order ID') AND preparationid IN ('section GUID') AND deletion = 'N';
        • Example:
          • UPDATE elnprod.mo_method SET deletion = 'Y' WHERE orderid IN ('2021000000474') AND preparationid IN ('9d8fbc88-1478-46fd-8aee-6d89d0cb7e72') AND deletion = 'N'
      4. Commit the change:   commit;
      5. Run the SQL statement on the NuGenesis database as the Elnprod or System user.
    • Export the affected documents with the LMS toolbox and send the DMP file to GSS. The team can try to recover the section contents and send the file to the development team for a root-cause analysis.

ADDITIONAL INFORMATION

Using manual logical LMS Document Section deletion in order to enable opening of a corrupt LMS document in the LMS Client would require corresponding manual Audit trail entries and should be avoided in a GXP environment.  It would be generally preferred to manually export and recover all LMS Document Sections possible from their raw OLE Object file - see KCS Article wkb45662 - and create a  new LMS Document from them; audit entries for that process being automated under system control.  

id190713, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG

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