Skip to main content
Waters

Unable to restore an Empower project backup from NuGenesis SDMS back to Empower - WKB16620

Article number: 16620

SYMPTOMS

  • The Empower project backup can be restored from the NuGenesis database, but restoring it to the Empower database results in the following error message:
    • "Error returned by ReadInfFile.  -2147220858 : Unknown Error"

ENVIRONMENT

  • NuGenesis 8 SDMS
  • NuGenesis 9 SDMS
  • Empower2
  • Empower3

CAUSE

The project backup as exported by the Empower Toolkit did not include the .INF file. SDMS archived the project backup, but Empower needs the INF file in order to restore the backup into its database.

FIX or WORKAROUND

Confirm the absence of the INF file:

  1. In NuGenesis WebVision, select the Empower project backup, and then click the File menu > View Details > File properties.
  2. Look through the list of files for the .INF file.
  3. If the .INF file is listed, re-restore the project from SDMS; if the file is not listed, click the "Leave files on disk" option within the Empower Restore Utility, and click Cancel.

Create a replacement INF file:

  1. If the original Empower project still exists in the Empower database, export the project manually through the Empower client
  2. If the original project does not exist, create a new project in Empower, with the same name and location within the project tree as the project that was backed up by NuGenesis.
  3. Export the project manually through the Empower client.
  4. Copy the .INF and .INF.CKS files from the manual Empower project backup to the set of files as restored from NuGenesis.
  5. Manually import the completed project backup using the Empower client.

ADDITIONAL INFORMATION

 

id16620, EMP2LIC, EMP2OPT, EMP2SW, EMP3GC, EMP3LIC, EMP3OPT, EMP3SW, EMPGC, EMPGPC, EMPLIC, EMPOWER2, EMPOWER3, EMPSW, SDMS, SDMS8, SDMS8NU, SUP, SUPISDMS, SUPNG

Not able to find a solution? Click here to request help.