Skip to main content
Waters

Error "[NG14599] Cannot find the specified template" appears in the log file when starting the NuGenesis Archive Agent - WKB13231

Article number: 13231

SYMPTOMS

  • The following error message appears in the SDMS Archive Agent log file:
    • GetExceptionServicesList: Error in getting Exceptions Services List. (14599): [NG14599] Cannot find the specified template. It may have been deleted or renamed. Please use a different template..
  • The Archive Agent does not start

ENVIRONMENT

  • NuGenesis 8 SDMS SR2
  • NuGenesis 8 SDMS FR1
  • NuGenesis 8 SDMS SR1

CAUSE

One or more of the templates in the Archive Agent's configuration uses either the Empower or the Chromeleon data adapter, and the template does not have an Exceptions List.

FIX or WORKAROUND

  1. Obtain the list of templates from the AA configuration:
    1. Log in to the NuGenesis Service Configuration Console with an administrator account.
    2. Select the Archive Agent module.
    3. Record the list of project templates displayed in the list.
  2. Confirm the presence of the Exceptions List in each template:
    1. Log in to SDMS Administrator.
    2. Open each template and look for Empower or Chromeleon archive template lines.
    3. Select one of the relevant lines and click Edit.
    4. Click the Advanced tab.
    5. Type a username and password in the input fields.
    6. Click Exceptions List to open the list.
    7. Make one minor change to the list and click OK.
    8. Click Save and Close to save the Exceptions List to the database.
    9. Repeat steps 1 through 8 for all templates.
  3. Restart the Archive Agent:
    1. Log in to the NuGenesis Service Configuration Console with an administrator account.
    2. Select the Archive Agent module.
    3. Click Start.

ADDITIONAL INFORMATION

If the Empower client is unreachable or retired, create a new template that excludes Empower projects.

id13231, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

Not able to find a solution? Click here to request help.