Error "The requested service could not be activated" when opening a document report in NuGenesis LMS - WKB12636
Article number: 12636
SYMPTOMS
- The following error message appears when a user clicks to view a document report in LMS:
- The requested service, 'https://servername/WATERSLMS/WebService/ExperimentReportService.svc', could not be activated.
- The document report does not open
ENVIRONMENT
- NuGenesis 9 LMS
- NuGenesis 8 LMS
- NuGenesis 8 ELN
CAUSE
The available free memory on the NuGenesis LMS server is less than 5% of the total memory in the server.
FIX or WORKAROUND
Add more memory to the server.
Modify the LMS web service's configuration so that services can launch with less than 5% of RAM available:
- On the LMS web server, open the web.config file for the WATERSLMS site. Find this file at:
- Drive:\inetpub\wwwroot\WATERSLMS\web.config
- Open the web.config file in Notepad.
- Look for the following lines in the file:
- <serviceHostingEnvironment multipleSiteBindingsEnabled="true">
- </serviceHostingEnvironment>
- Modify the lines as follows:
- <serviceHostingEnvironment multipleSiteBindingsEnabled="true" minFreeMemoryPercentageToActivateService="1">
- </serviceHostingEnvironment>
- Save and close the file.
- Open Control Panel > Administrative Tools > IIS Manager.
- Select the default server, and on the right-hand side under "Manage server", click Restart.
ADDITIONAL INFORMATION
id12636, ELN, SUPNG