"Printer not activated, error code -30" when trying to save a PDF in Report Publisher in Empower 3 - WKB3128
Article number: 3128
SYMPTOMS
- The "Printer not activated, error code -30" message appears when you try to save a PDF file in Report Publisher or save in Export Methods.
ENVIRONMENT
- Empower 3
CAUSE
"Print" function used in Report Publisher.
This can also occur when Save As function used as this is due to corrupt or missing drivers.
FIX or WORKAROUND
- Use the "Save As" function to save a PDF file in Report Publisher.
- If this fails to work then run Configpdfdriver.bat file.
- If Configpdfdriver.bat file is missing or been deleted then this and likely the *.dll files listed in additional information will need to be downloaded and installed in C:\windows\system32\spool\drivers\x64. They have likely been deleted or are corrupt. If present when navigating to the folder location replace with the new versions. Reboot the PC, then run Configpdfdriver.bat.
- Launch Empower and check the files can now be saved as pdf.
- You may need to contact Waters Technical Support for the drivers. 1-888-292-8377.
ADDITIONAL INFORMATION
- The Waters PDF Generator is intended for background use by the software, not as a user option for printing.
- To reinstall the Waters PDF Generator, navigate to C:\Empower\bin\Configpdfdriver.bat and double click the file.
- If file is missing follow instructions in Fix/Workaround above.
- The *.dll files needed, the acfpdf.txt document was also transferred.
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