Error: Failed to start application (Report Publisher in Empower 3) - WKB2950
Article number: 2950
SYMPTOMS
- Highlight results > right-click and click on Preview Publisher > Error: Failed to start application (Report Publisher)
- No changes made to DCOM settings
- A server reboot does not resolve error
- Under Windows Environment Variables > System Variables, "C:\Empower\Bin" is listed
- Cannot launch Report Publisher by clicking on C:\Empower > Bin folder > Report Publisher.exe
- Error appears only on virtual machine, not on physical machine
ENVIRONMENT
- Empower 3 SR2 HF2
- Virtual machine
CAUSE
The registry entry for Report Publisher is incorrect.
FIX or WORKAROUND
- Launch the registry editor in Windows by clicking Start and then typing regedit in search. (If registry editor does not launch, log in as an admin.)
- Under HKEY_LOCAL_MACHINE, search for Report~1 or
go to \HKEY_LOCAL_MACHINE\Software\Classes\Wow6432Node\CLSID\{9F80F443-E207-11CE-918D-0020AFEE2C83}\LocalServer32.
-
Data on right for Default entry needs to be "C:\Empower\Bin\Report Publisher.exe" instead of "C:\Empower\Bin\Report~1"
- Edit path to match the example, C:\Empower\Bin\Report Publisher.exe (see screen shot below).
ADDITIONAL INFORMATION
id2950, EMP2LIC, EMP2OPT, EMP2SW, EMP3GC, EMP3LIC, EMP3OPT, EMP3SW, EMPGC, EMPGPC, EMPLIC, EMPOWER2, EMPOWER3, EMPSW, SUP