"PreConfigClient has stopped working" error when using the PreConfiguration utility through Empower on the LAC/E - WKB27421
Article number: 27421
SYMPTOMS
- "PreConfigClient has stopped working" error when opening the PreConfiguration utility through Empower on the LAC/E
- Cannot launch the PreConfiguration utility
- Agilent LC folder on LAC/E is missing a majority of files, including Agilent.InstrumentControl.InstrumentPreConfigurator.exe
ENVIRONMENT
- Empower
- ICF Support v2.2 with A.02.04
- ICF Support v3.0
CAUSE
Agilent Instrument Control Framework, Agilent Instrument Control Framework - LC Drivers, and Agilent Instrument Control Framework - GC Drivers are installed in an incorrect location.
In an incorrect installation, the files from these component installations are likely to be found in C:\Program Files (x86)\Agilent Technologies.
In a correct installation, the files from these component installations are found in C:\Empower\Instruments\AgilentLC.
FIX or WORKAROUND
- Using the Add/Remove Programs or the Programs and Features control panel, remove the existing Agilent components. These may include Agilent Instrument Control Framework, Agilent Instrument Control Framework - LC Drivers, and Agilent Instrument Control Framework - GC Drivers.
- Remove ICF Support using the Waters Deployment Manager.
- Reinstall the required ICF Support version and any required updates.
ADDITIONAL INFORMATION
Link to instructions for use of the PreConfiguration utility: Using the Agilent PreConfiguration Utility with Agilent Instrument Control Framework (ICF) Support Version 2.2
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