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AgilentPlugInServer.exe crash with Agilent GC with HS systems using ICF Support Layer 3.5 and above - WKB252975

Article number: 252975

SYMPTOMS

  • Instrument Failure AgGC#XXXXX message appears in message center
  • Communication Failure message appears in ICF log
  • Windows Application Event Log shows Application Error with AgilentPluginServer.exe as the faulting application
  • Windows Application Event Log shows .NET Runtime event with AgilentPluginServer.exe experiencing an unhandled exception

ENVIRONMENT

  • Empower 3
  • Agilent ICF Support Layer 3.5 and above
  • Agilent GC
  • Agilent LC

CAUSE

This behavior is recorded as CRI-5480. It is still under investigation by the Agilent team. Through various versions of ICF drivers, Agilent has implemented many fixes that reduce the occurrences of this problem. With the latest version of drivers, the frequency of this issue is reduced further.

FIX or WORKAROUND

  1. It is recommended that the customer restart LAC/E and GC regularly. Restarting every week is a good choice.
  2. If the error occurs, an engineer should help the customer collect the relevant logs.
  3. See the following articles for log collection methods:
  • Agilent ICF logs and Lab Advisor diagnostic buffer logs - WKB65971
  • Agilent third-party logs - WKB227265
  • Instrument Server logs and ICS logs - WKB75196

ADDITIONAL INFORMATION

 

id252975, 7890 GC, 7890 GCDET, 7890BGC, comms

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