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Empower project backup does not complete; "Failed to copy" EXP error - WKB238074

Article number: 238074

SYMPTOMS

  • "Failed to copy" error
  • Project backup action stops and does not complete

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ENVIRONMENT

  • Empower
  • Project backup
  • Backup of the entire Empower project hierarchy
  • Typically not seen with backup of single projects

CAUSE

OS user profile is using a roaming TEMP location that can be locked transiently by other processes.

During the backup of a project, the EXP and backup.log are generated in the TEMP location before being moved to the project backup folder when the backup is completed.

If they cannot be moved when completed, the backup fails.

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FIX or WORKAROUND

  1. Create an Empower service OS account.
  2. Set the TEMP location for this account to C:\TEMP.

ADDITIONAL INFORMATION

Avoid copying to redirected mapped network locations. - https://support.waters.com/KB_Inf/Empower_Breeze/WKB220896_Error_Failed_to_copy_EXP_file_when_backing_up_projects_in_Empower 

Anything else (such as AV scanning) that prevents the files being moved can cause the same issues.

In this case, the customer had not implemented the Waters validated backup scripts for backup of the database. They were using Project backup weekly to backup the data. The Waters validated backup scripts or WDM backup are the only way to recover the database and prevent data loss.

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