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Poor performance in Empower Enterprise; processing of data is very slow with full Empower acquisition clients - WKB205731

Article number: 205731

SYMPTOMS

  • Poor performance of the application for a specific site
  • Processing of data is very slow.
  • Opening a sample set comprising one sample (that has 15-20 channels) takes more than one minute
  • When the first injection is finished, loading can go through the different channels quickly
  • Clicking next injection, it again must load and takes the same amount of time (one minute)
  • Making a new project, copying files from a different folder, it says “not responding” and the copying process stops; a few hours later it finishes
  • The processing of a sample set of six samples takes approximately 30 minutes
  • Opening data in preview publisher only works if the screen of the processing of data is empty; if this is not the case, the report does not load all files
  • The loading of all files in a report (if processing screen is empty) takes 5-10 minutes

ENVIRONMENT

  • Enterprise
  • Server 2016 Datacenter
  • Full Empower acquisition clients
  • WAN

CAUSE

The network had moderate latency and is the site farthest from the Empower server affected.

Approximate round-trip times in milliseconds:   Minimum = 10 ms, Maximum = 19 ms, Average = 10 ms

Processing on the server proceeds as expected and is quick.

FIX or WORKAROUND

  1. Install full Empower client in the same datacenter as the Empower database. Remote access it for processing tasks.
  2. Consider implementation of Citrix.

ADDITIONAL INFORMATION

The customer had the following parameters set.

SQLNET.AUTHENTICATION_SERVICES = (NONE)
SQLNET.EXPIRE_TIME = 5
SQLNET.INBOUND_CONNECT_TIMEOUT=120

This was changed to the default SQLNET.EXPIRE_TIME = 10 but did not resolve.

Additionally, also checked and disabled:

1) DBA Recycle bin disabled and emptied. 
2) SQL tuning task disabled and observed a small improvement loading the SS in review on the client. 

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