What does "Oracle Error ORA-01805" indicate? - WKB16369
SYMPTOMS
- Empower client generates Message Center error: Oracle Error ORA-01805: possible error in date/time operation
- Strange or weird date time stamps are seen for acquired data
ENVIRONMENT
- Empower 3 FR2, FR3, FR4, FR5
- Empower 3.6.x and higher
CAUSE
Oracle is attempting to reference LAC/E32 (acquisition server) installed Oracle timezone files that are missing, corrupted, or mismatched with the server timezone files. This is seen during buffering when time stamps are being referenced from the LAC/E32 instead of the Empower database server.
FIX or WORKAROUND
Contact Waters Support for assistance - https://docs.oracle.com/en/error-help/db/ora-01805/?r=23ai
ADDITIONAL INFORMATION
Empower FR2 and FR3 have two sets of 14 timezone .dat files by default when installed from the Empower DVD.
FR4 has two sets of 18 timezone .dat files by default.
FR5 has 31 timezone.dat files by default. Sometimes Oracle admins will add Oracle patches that add additional time zone files into the Empower database server released by Oracle to accommodate time zone changes made by different countries or states. The same patches need to be added to all of the LAC/E32s or acquisition clients that are on the Empower database server or you will see strange or weird time stamps when buffering occurs. If clients are not patched as well, you may see processing or Empower logon ORA-01805 errors.
Example of where Oracle client timezone files are found on a LAC/E32 or acquisition server client
C:\Empower\Oracle\Oracle11gClient_4\oracore\zoneinfo
Example of where Oracle client timezone files are found on an Empower database server (including the workstation/personal deployment):
H:\Empower\Oracle\Oracle18c\oracore\zoneinfo
Example of where Oracle client timezone files are found on a personal workstation:
C:\Empower\Oracle\Oracle11gClient_4\oracore\zoneinfo
id16369, EMP2LIC, EMP2OPT, EMP2SW, EMP3GC, EMP3LIC, EMP3OPT, EMP3SW, EMPGC, EMPGPC, EMPLIC, EMPOWER2, EMPOWER3, EMPSW, SUP