ORA-03113 End-of-file on communication channel - WKB1129
Article number: 1129
SYMPTOMS
- Error message is typically presented when session established between any Empower executable and the Oracle database is terminated improperly.
ENVIRONMENT
- Empower Client/Server Environment
CAUSE
- The most common cause has been found to be network devices configured to terminate idle connections.
FIX or WORKAROUND
- Inspect network devices for any default or configured timeout values. Disable any timeouts.
- Try setting TCP KeepAlive on servers.
ADDITIONAL INFORMATION
To test this, launch several windows at the same time. Leave all windows idle except for one. Access an idle window at different designated times (after 15 mins, after 20 mins, after 25 mins, after 30 mins, after 45 mins, after 60 mins). While accessing these windows on a different time interval, see when the first instance of ORA-03113 comes up. This is the timeout value in use.
- The default TCP keepalive time interval in Windows is 2 hours. If other things are set to timeout with lower values, TCP keepalive will not be initiated.
- After a period (KeepAliveTime) of inactivity, the server will send ACK packets at specified intervals (KeepAliveInterval) up to the maximum number specified.
- TCP KeepAlive registry keys to set on the servers:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\
* time values are set in milliseconds
- https://learn.microsoft.com/en-us/answers/questions/1115172/keepalivetime-registry-setting-for-windows-server
- https://www.alitajran.com/tcp-keepalivetime-exchange-server/
- https://en.wikipedia.org/wiki/Keepalive
