MS detector is not present in console, and control panel is unavailable in Empower due to driver conflict- WKB2858
Article number: 2858
SYMPTOMS
- The QDa is not displayed in the console view
- The QDa is identified as an "MS Detector" in the Run Samples window, but the specific model is not listed, and the MS window is unavailable.
- The device IP address populates in the DHCP server, but the instrument type is not identified
- Pings to the EPC are as expected
- Communications to the MS via telnet can be established
ENVIRONMENT
- Empower
- ACQUITY QDa
- ACQUITY SQD
- ACQUITY TQD
- ACQUITY 3100
- SQ Detector 2
- Control panel
- Citrix
CAUSE
- Both QDa and SQD/SQD2 ICS/drivers are installed, which prevents control of the QDa through console software and the control panel
(Can be seen in Control Panel > Programs and Features) - Driver conflict when multiple MS Detector ICS/drivers are installed on the acquisition PC
FIX or WORKAROUND
A single MS driver should be installed on the acquisition PC:
- Remove all MS drivers.
- Reboot the computer.
- Install the appropriate MS driver.
- Reboot the computer.
- Log in to the acquisition PC.
- Clear the MS entry in the DHCP server.
- Reboot the MS.
- Verify that the MS is now populated in the console and can be controlled.
Other resolution :
- If several MS Drivers are installed on the same Empower client, install at the end the MS detector that you will connect to this computer (or the QDa for Citrix server).
- If this installation order was not done, change the registry key to [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Waters\Instruments]
'MSDetector'='ACQ-QDA'
ADDITIONAL INFORMATION
id2858, A-SQ, comms, EMP2LIC, EMP2OPT, EMP2SW, EMP3GC, EMP3LIC, EMP3OPT, EMP3SW, EMPGC, EMPGPC, EMPLIC, EMPOWER2, EMPOWER3, EMPSW, QDA, SQD, SUP, TQD, TQDIVD