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HPLC Service error: "Instrument Connection Failure!" after a configuration change - WKB313295

Article number: 313295

SYMPTOMS

  • When trying to connect HPLC Service to Agilent instruments after a configuration change, HPLC Service fails to connect to the Agilent instruments
  • Error message "Instrument Connection Failure!" (See the screen shot below for an example of the error message.)
  • Error details show "A configuration change was reported from the driver. This change was not handled correctly (see driver logfile for details)"
  • Agilent instruments can still connect to Agilent software and Agilent.InstrumentControl.TestApp

HPLCServiceInstrumentConnectionFailure.png

ENVIRONMENT

  • HPLC Service
  • HPLC Connect

CAUSE

Instrument configuration file contains old information

FIX or WORKAROUND

  1. Navigate to C:\ProgramData\Agilent Technologies\Instrument Control Framework
  2. Locate the instrument configuration file with the format "<ip address>.xml" (e.g. 192.168.254.11.xml)
  3. Rename the file and append "_old" to the end of the filename (e.g. 192.168.254.11_old.xml)
  4. Restart HPLC Tray
  5. Select HPLC Tray and open the Configuration Window
  6. Change the IP address to 0.0.0.0 and press Enter
  7. Click Apply to clear the IP address
  8. Enter the correct IP address
  9. Click Apply to set the IP address
  10. Connect to the Agilent detectors

ADDITIONAL INFORMATION

The Agilent Instrument Control Framework can only support one client at a time. Make sure that no other software is attempting to connect to the Agilent instruments when using HPLC Service.

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