Skip to main content
Waters

Cannot delete folder or change folder status - WKB13835

Article number: 13835

SYMPTOMS

When attempting to delete a folder or change the status of a folder, the following error messages appear:

Cannot Delete Folder
Cannot delete this folder because of one of the following reasons:

  • The folder or sub-folder contains items that are locked for write
  • The folder or sub-folder contains items that are marked for export
  • The folder or sub-folder contains pending acquisitions
  • The folder or sub-folder contains items that are pending signature sequence
  • The folder or sub-folder contains an item that resides in user's Work In Progress

image.png

ENVIRONMENT

  • UNIFI 1.9.4 and earlier
  • waters_connect 

CAUSE

  • Items open for editing by another user
  • Items open in Work in Progress (WIP)
  • Items awaiting a signature
  • Hidden lock defects US1#210276, US1#214901, US1#215112
  • CRI-449, CRI-7183, CRI-9017

FIX or WORKAROUND

First of all, check for the legitimate reasons outlined above—items open in Work in Progress (WIP), pending signatures, edit locks with other users.

NOTE: Edit locks can now be removed by the user in waters_connect 2.1.2 and later using the right-click menu "Remove Edit Lock" in Explorer.

  1. From Explorer, navigate to the folder.
  2. Right-click on the column headers bar and choose "Add column" from the menu that appears.

add column.png

3.From the Add Columns window, expand contents under Common Fields and highlight the "Locked By" choice.lockedby.png

4. Select the right-facing arrow to add it to the Selected Fields pane. (You can use the up and down arrows to position this column.)

5. Sort the table so the locked items are identified. 

6. Resolve the problem to remove the lock on the particular item.

7. Proceed with the delete or status change for the folder.

8. If these steps fail, contact Waters Global Support because it may be an example of a hidden lock defect that requires unlocking in the database.

ADDITIONAL INFORMATION

Not able to find a solution? Click here to request help.