Error "LMS Interface Tables Missing" appears when sending data to Empower through the LMS-Empower Interface - WKB82811
SYMPTOMS
- The following error message appears in LMS when sending a Sample Set Method to Empower:
-
---------------------------
LMS Interface Tables Missing
---------------------------
Waters.ELN.ToolKit: Unknown logon failure
select SUBMISSIONGUID, ANALYSISMETHOD, DOCUMENTID, PROPOSEDSSMPATTERN, PROPOSEDSSMNAME, SUBMITTER, max( SUBMITDATETIME ) from INSTRUMENTHUB where upper( ANALYSISSYSTEM ) = 'EMPOWER' and STATUSSAMPLE = 'Submitted' and trim( PROPOSEDSSMPATTERN ) is not null and trim( ANALYSISMETHOD ) is not null and trim( SAMPLEID ) is not null and SUBMISSIONGUID = '9d04754f-ac9f-4cb3-aa4f-6f3db6639b2e' group by SUBMISSIONGUID, ANALYSISMETHOD, DOCUMENTID, PROPOSEDSSMPATTERN, PROPOSEDSSMNAME, SUBMITTER order by 7 desc, 6, 2, 3, 5, 4, 1
while connecting to http://servername:8080/vp/services/ with ADMIN
[Waters.ELN.ToolKit.SessionContext.logOn(String serverPath, String user, String password, Boolean useAuthentificate)]
---------------------------
OK
---------------------------
-
ENVIRONMENT
- NuGenesis 9 LMS
- NuGenesis 8 LMS
- NuGenesis LMS-Empower Interface
CAUSE
The connection URL for the LMS server, or the stored LMS credentials, are incorrect.
FIX or WORKAROUND
- Open the file Drive:\ProgamData\Waters\LMS Empower Interface\ELNEmpower.ini.
- Verify the URL in the ELNConnect parameter. Ensure that the server name, the port number, and the URI fragment are correct. The default port number is 8180 and the URI fragment is /vp/services/.
- For NuGenesis 9.3 the default port number is 8443
- Save and close ELNEmpower.ini.
- Open the file %appdata%\Waters\LMS Empower Interface\ELNEmpowerUser.ini.
- Verify that the username in the "ELNUser" parameter is a valid and unlocked user account in NuGenesis LMS.
- Enter the password for that account in the ELNPasswd parameter. The interface will encrypt this password when it next runs.
- Save and close ELNEmpowerUser.ini.
ADDITIONAL INFORMATION
