Skip to main content
Waters

Duplicate document IDs created in NuGenesis LMS - WKB59653

Article number: 59653

SYMPTOMS

  • Users cannot create documents in NuGenesis LMS. The following message appears in LMS when creating a new document:
    • Please correct the highlighted errors first!
  • When clicking OK to the message box, the document ID field is highlighted in red, and the message text appears when moving the mouse over the field:
    • A document with the provided Document ID already exists
  • In other cases, the document may be created, but the document ID may be indistinguishable from IDs created by other users
  • IDs for reagents or instruments may not be unique if they are based on the document IDs

ENVIRONMENT

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS
  • NuGenesis 8 ELN

CAUSE

The document ID pattern does not incorporate enough uniqueness to prevent the generation of duplicate or similar IDs.

FIX or WORKAROUND

Waters recommends using at least the following elements in the document ID pattern:

    1. The full date stamp, as in YYYYMMDD
    2. Three or more digits for the system-wide document counter or the per-user document counter
    3. At least 8 characters of the department name, team name, or the user ID
    4. No Reset on the system and user document counters

ADDITIONAL INFORMATION

Using the full date/time stamp in the ID—YYYYMMDDHHMISS—is often enough to create unique IDs, but it tends to create hard-to-remember IDs.

If the department, team, or user ID is incorporated into the ID pattern, use enough characters to ensure uniqueness across similar names.

Not able to find a solution? Click here to request help.