Empower system audit trail is not archived by NuGenesis SDMS - WKB57607
SYMPTOMS
- The Empower system audit trail is not backed up by NuGenesis
- The following messages are logged in the Archive agent's activity log, depending on whether the SDMS template is Auto or Manual archive of the audit trail:
-
"E ","datetime ","5 ","5 ","Argument 'Start' must be greater than zero. ","Waters.SDMS.WindowsService ","clsEmp2AuditPreProc ","GetProjectList ","1 ",""
"E ","datetime ","-1 ","-1 ","Backup maa files failed. ","Waters.SDMS.WindowsService ","clsEmp2AuditPreProc ","PerformAuditPreProcess ","1 ",""
"E ","datetime ","-1 ","-1 ","error in Remote PreProcess method ","Waters.SDMS.EmpowerDAProxy ","clsMillPreProc ","PerformPreProcess ","1 ",""
"E ","datetime ","-1 ","-1 ","PreProcessor call failed for the remote server: EMP3WIN10VM1 ","Waters.SDMS.EmpowerDAProxy ","clsMillPreProc ","PerformPreProcess ","1 ","" -
"E ","datetime","57 ","57 ","Logon failure: unknown user name or bad password.
","Waters.SDMS.WindowsService ","clsEmp2AuditPreProc ","GetProjectList ","1 ",""
"E ","datetime","-1 ","-1 ","Backup maa files failed. ","Waters.SDMS.WindowsService ","clsEmp2AuditPreProc ","PerformAuditPreProcess ","1 ",""
"E ","datetime","-1 ","-1 ","error in Remote PreProcess method ","Waters.SDMS.EmpowerDAProxy ","clsMillPreProc ","PerformPreProcess ","1 ",""
"E ","datetime","-1 ","-1 ","PreProcessor call failed for the remote server: IBDCLIENT ","Waters.SDMS.EmpowerDAProxy ","clsMillPreProc ","PerformPreProcess ","1 ",""
-
-
The audit trail ".maa" files can be archived by NuGenesis if the Empower audit trail is manually backed up to the scan path
ENVIRONMENT
- NuGenesis 9 SDMS
- NuGenesis 8 SDMS
- Empower 3
CAUSE
- The Empower system audit trail policy for the Project object requires a comment and/or requires identity confirmation;
- The "Short date" format in the OS on the Empower machine is set to other than "mm/dd/yyyy";
- The "Waters SDMS EmpowerDA DataExchange Service" is unable to authenticate to the domain due to an expired password for the computer account
FIX or WORKAROUND
Defect report CRI-207 has been filed for this issue.
- Set the system audit trail policy in Empower:
- Log in to the Empower configuration manager
- Click View > System Policies
- Select the System Audit Trail tab
- Set the policy for the "Project" object as follows:
- Comment: Silent
- Confirm Identity: not selected
- Click OK
- Set the Short Date format in the OS on the Empower client and server to mm/dd/yyyy
- Move the machine from the domain into a workgroup; restart the machine; add it back to the domain.
ADDITIONAL INFORMATION
See also: Empower system audit trail is not archived by NuGenesis 8 SDMS from Empower 3 SR3
id57607, EMP2LIC, EMP2OPT, EMP2SW, EMP3GC, EMP3LIC, EMP3OPT, EMP3SW, EMPGC, EMPGPC, EMPLIC, EMPOWER2, EMPOWER3, EMPSW, SDMS, SDMS8, SDMS8NU, SUP, SUPISDMS, SUPNG