Errors are seen in the new NuGenesis SDMS WebVision interface during the 12th-19th days of the month - WKB308351
Article number: 308351
SYMPTOMS
- Users who log in to SDMS WebVision with LDAP logins are unable to log in
- The following error message appears in the log file for the SdmsIdentity site on the SDMS Web server for each LDAP login during this period:
- ERROR|Sdms.Identity.Core.AppServices.Requests.Behaviors.ExceptionHandling.ExceptionHandlerPipelineBehavior|Parameter cannot be empty System.ArgumentException: Parameter cannot be empty
- Users who log in with an Oracle account (such as ngprojmgr) can log in to WebVision and search/browse projects; however, restoring files or previewing reports results in this error:
- Could not view the selected record(s)
- The following message appears in the log file for the SdmsProjects site for each download request:
- ERROR|Sdms.Projects.Core.AppServices.Requests.Behaviors.ExceptionHandling.ExceptionHandlerPipelineBehavior|Value cannot be null. (Parameter 's') System.ArgumentNullException: Value cannot be null. (Parameter 's')
- Developer Tools on MS Edge gives the error:
- 500 Internal Server Error
ENVIRONMENT
- NuGenesis SDMS 9.4
CAUSE
The library that SDMS uses for password encryption throws an error on the 12th-19th days of each month, despite SDMS internally invoking it with a valid license key.
FIX or WORKAROUND
- Apply NuGenesis 9.4 Hotfix 1.
- Use the legacy WebVision interface to preview or restore files during that time window.
- Alternatively, the server's system clock could be reset to the 11th or 20th of the month, but this is NOT recommended for a production system, and it may be blocked by group policy.
ADDITIONAL INFORMATION
