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Unable to preview file records from NuGenesis SDMS on Windows 10 clients - WKB20280

Article number: 20280

SYMPTOMS

  • Error messages similar to the following appear when opening file records with the "QuickRestore" function in NuGenesis WebVision:
    • "The system cannot find the path specified."
    • "The directory name isn't valid." (C:\Program Files\...\filename)
  • The files are not opened.
  • The error message is presented by the registered application for the file type, and thus, the message text may differ from the two examples.

ENVIRONMENT

  • NuGenesis 8 SDMS SR2
  • Windows 10
  • Windows 8.1

CAUSE

The NuGenesis Transfer Application is configured to use an invalid or inaccessible path for its Temp folder.

FIX or WORKAROUND

  1. Edit the following registry key in Regedit:
    • HKLM\SOFTWARE\WOW6432Node\NuGenesis Technologies Corp.\NuGenesis\8.0\Preview\TempFolder
  2. Set the content of that key to %TEMP% so that the Transfer App uses the Temp folder in the user's profile path.
  3. Close Regedit.

ADDITIONAL INFORMATION

The default path for the NuGenesis Temp folder was, prior to NuGenesis 8 SR2, Drive:\Program Files (x86)\NuGenesis 8.0\Temp. With the advent of stricter default permissions in Windows 8, 8.1, and 10 that prevent users from writing to the Program Files folders, the default value was changed to %TEMP%. The new default value is applied for new installations of the NuGenesis Transfer App software. However, for existing client who are upgraded to SR2, the old Temp folder path is retained. The registry key must be manually verified after SR2 client upgrades and set to %TEMP% if found to use the older default path.

Using a temp folder in the Program Files directories was acceptable with Windows 2000, XP, and some 7 clients due to the lenient default permissions in those operating systems. If a client's OS is upgraded to Windows 8.x or Windows 10, then this registry key must be updated to comply with the strict permissions in the latest Windows releases.

Confirm that the transfer application from the Windows 10 client media is installed correctly on the client machine.

id20280, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

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