Unable to log in to the NuGenesis SDMS Audit Trail Viewer - WKB17253
Article number: 17253
SYMPTOMS
- The following error message appears when logging in to the SDMS Audit Trail:
- "A general exception occurred during database access."
- Clicking OK to the message takes the user to the Audit Trail's main page, but no Data Views are available, and the audit trail viewer is not functional
- The following error message appears in the Apache Tomcat log file:
- "Exception: java.sql.SQLException: [Oracle][ODBC]Driver not capable."
- The NuGenesis SDMS WebVision site is functional
ENVIRONMENT
- NuGenesis 9 SDMS
- Windows Server 2012 or 2016
- Applicable to the legacy Audit Trail Viewer web app in NuGenesis 9.1, but NOT to the new Audit Trail Viewer web app
- NuGenesis 8 SDMS
- Windows Server 2008 or 2012
CAUSE
The ODBC driver settings for the NuGenesis system DSNs on the web server are not configured correctly.
FIX or WORKAROUND
- Log in to the NuGenesis SDMS web server.
- Click Start menu > All Programs > Waters Oracle Client > Configuration Tools > Microsoft ODBC Administrator.
- Click the System DSNs tab.
- Select "_NG_PROJ80_ORACLEINFO_" (NuGenesis 8) or "_NG_PROJ_ORACLEINFO_" (NuGenesis 9) and click the Properties button.
- Set the properties as listed below on the Application, Oracle, Workarounds, and SQLServer Migration tabs:
- Application:
- Enable Result Sets: selected
- Enable Query Timeout: selected
- Read-Only Connection: not selected
- Enable Closing Cursors: not selected
- Enable Thread Safety: selected
- Batch Autocommit Mode: Commit only if all statements succeed
- Numeric Settings: Use Oracle NLS settings
- Oracle:
- Fetch buffer size: 64000
- Enable LOBs: selected
- Enable statement caching: not selected
- Cache buffer size: 20
- Enable failover: selected
- Retry: 10
- Delay: 10
- Workarounds:
- Bind TIMESTAMP as DATE: selected
- Disable SQLDescribeParam: not selected
- Force SQL_WCHAR Support: not selected
- Bind NUMBER as FLOAT: not selected
- Disable Microsoft Transaction Server: selected
- Disable RULE Hint: selected
- Set Metadata Id Default to SQL_TRUE: not selected
- SQLServer Migration:
- Enable EXEC Syntax: not selected
- Application:
- Click OK.
- Verify that the properties of the other DSN (_NG_PROJLIST_MASTER80_ / _NG_PROJLIST_MASTER_) are configured as above.
- Close any open browser sessions and log back in to the NuGenesis Audit Trail viewer.
ADDITIONAL INFORMATION
See also:
- Error: "Could not locate database driver" in NuGenesis Audit Trail Viewer
- Error: "java.lang.NumberFormatException" occurs on logging in to the SDMS Audit Trail
id17253, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG