Error "Could not connect to the server provided" appears when loading the new SDMS Audit Trail and the app has been configured with a domain name - WKB124234
Article number: 124234
SYMPTOMS
- The following message appears in red text on the login page for the new Audit Trail Web app for SDMS:
- Could not connect to the server provided. Please check the network connection or the database configuration.
- The list of servers on the Audit Trail Web app's login page is empty
- Per article WKB110157, the envConfig.json file and the IIS configuration have been updated to use a fully qualified domain name, but the issue persists
- In the Developer Tools in Edge or Chrome, the network trace shows error 504 for the request for "login-servers"
- Loading the login-servers URL directly in the Web browser results in HTTP error 500.19
- Example URL: https:// webserver:54822/sdmsweb/api/login-servers
ENVIRONMENT
- NuGenesis SDMS 9.3
CAUSE
The .NET Core Web Hosting Bundle is not installed on the NuGenesis SDMS Web server.
FIX or WORKAROUND
- Download and install the latest .NET Core Web Hosting Bundle on the Web server.
ADDITIONAL INFORMATION
Ensure that the the C:\Program Files (x86)\Waters\NGSDMS\Application Server\AuditTrail\ClientApp\assets\config\envConfig.json file is configured as follows, with fully qualified Domain Name in hostname and the domain in domain.
After making the change to the file, save the file and restart IIS.

