Error "Could not connect to the server provided. Please check the network connection or the database configuration" when loading new Audit Trail Web app for NuGenesis SDMS - WKB110157
Article number: 110157
SYMPTOMS
- The following message appears in red text on the login page for the new Audit Trail Web app for SDMS:
- Could not connect to the server provided. Please check the network connection or the database configuration
- The list of servers on the Audit Trail app's login page is empty
ENVIRONMENT
- NuGenesis 9.1 SDMS
CAUSE
The new audit trail Web app's configuration has a bare server hostname for the audit trail's server component, and the Web browser blocked download of the server list because the server hostname does not match the certificate provided by the Web server.
FIX or WORKAROUND
- Modify the envConfig.json file on the SDMS Web server to use the fully qualified domain name:
- Edit the file in Notepad: Drive:\Program Files (x86)\Waters\NGSDMS\Application Server\AuditTrail\ClientApp\assets\config\envConfig.json
- For the "hostname" entry, type the fully qualified domain name for the server.
- Save and close envConfig.json.
- Modify the AuditTrailRedirectRule URL Redirect Rule in IIS:
- Open IIS Manager on the SDMS Web server.
- Select the local server.
- Double-click URL Rewrite.
- Double-click the "AuditTrailRedirectRule".
- Scroll to the end of the page.
- Modify the "Redirect URL" by appending the DNS Suffix to the hostname and Apply the changes.
- Example: "https://servername:444" to "https://servername.domain.com:444"
- Confirm that "Append query string" is active and that the redirection type is 301.
- Remove the server name from the IIS bindings:
- Open IIS Manager on the SDMS Web server.
- Expand the list entry for the local server and select the site "AuditTrailClientApp".
- Click "Bindings".
- Select the binding for https and click Edit.
- Clear the Host Name field.
- Click OK.
- Repeat steps 3-6 for the site "AuditTrailWebServer".
- Restart IIS.
- Reload the Audit Trail login page.
ADDITIONAL INFORMATION
Even after applying the fix/workaround, when some users try to access a URL like https://servername.domain.com/sdmsapp in Chrome, they get a "Your connection is not private" error.
There are two options to work around this:
- Click "Advanced" and allow to trust the connection.
- Use the URL https://servername.domain.com:444/log-viewer instead.
id110157, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG