Skip to main content
Waters

Quanpedia hangs when click on Options or Advanced Mode - WKB96586

Article number: 96586

SYMPTOMS

After Quanpedia opens successfully, at times the application may hang when you click on the Options menu or select Setup or switch into Advanced mode.

ENVIRONMENT

  • MassLynx 4.2
  • Windows 10 
  • TargetLynx
  • Quanpedia

CAUSE

Unknown but most likely to be seen on an unsupported computer / operating system, especially if that laptop is being used to connect to the MassLynx PC using remote desktop connection (RDC). However, the issue is occasionally seen on Waters Windows 10 PCs where there is no remote connection and no touch screen.  

Note: MassLynx (4.2) acquisition is only supported and tested on Waters supplied PCs with either on English version of Microsoft® Windows® 10 Enterprise LTSB 1607 on a Waters-supplied acquisition workstation. (Or Microsoft® Windows® 7 Professional 64-bit, Service Pack 1)

FIX or WORKAROUND

Possible workarounds:

Option 1: for 3rd party unsupported laptops

Disable Touch Screen in Device Manager. If that does not help, try disabling Touch Pad. 

Control Panel > Device Manager > Human Interface Devices > HID compliant touchpad

 

Option 2: where touch screen and touch pad are not being used or are not available. 

  • End the Quanpedia process CMDB.exe in Task Manager and then restart QuanPedia. 
  • Click Run Samples or Run Compounds
  • Proceed through the steps and then click on the browse button for project selection, select a new project and then click Cancel.
  • The view can now be switched into Advanced mode. 

Note: This will need to be done each time Quanpedia is opened.

The 2nd workaround does not give access to the Options menu.However, the template files and the QP database can be changed via the following registry key

  • Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Micromass\CompoundDatabase

 

If it's a Waters PC, re-imaging the PC might fix this problem. Reinstalling MassLynx is unlikely to help. 

 

ADDITIONAL INFORMATION

Development: This happens because we use an old version of WPF (Windows Presentation Foundation) that is no longer supported by Microsoft and there are bugs in Windows 10 in how it is implemented. It is unlikely to be fixed. 

 

id96586, MLYNX, MLYNXV41, SUPMM

Not able to find a solution? Click here to request help.