Skip to main content
Waters

Cannot log in due to Oracle-1 error on Empower Workstation - WKB302312

Article number: 302312

SYMPTOMS

  • Cannot log in to Empower Workstation due to Oracle-1 error
  • ORA-12541: TNS:no listener
  • ORA-12514: TNS:listener does not currently know of service requested in connect descriptor

ENVIRONMENT

  • Empower
  • Workstation PC
  • Empower Personal
  • Windows 10 environment

CAUSE

TNSListener services not getting communication to Oracle Service.
TNSListener Service not started.

FIX or WORKAROUND

1. Add the loop back adapter and assign an IP (10.10.10.1).
2. My Computer >                    clipboard_ec163cda228a008273073d107db76a458.png
3. Add Legacy Hardware >            clipboard_e2fdc3dfd235f832fd7f08b4ae9ceab7a.png

4. Add Driver for Network >            clipboard_edabca2a27ef233ae1491177a706f8229.png
5. Finish Installation >                        clipboard_ef3ace4360ca2116d6387c2a488f0ce89.png

6. Add IP in Loop back Adaptor Properties IPv4 >    clipboard_eb38043d468f9ba284fde11121e8e4a64.png    
7. Run Notepad as Administrator and open the Host file (select All files in Notepad).

            clipboard_e5a4808f7946df30c096b526c370f62f4.png

9. Add IP in host file (10.10.10.1 <space> Device Name) and save. Device name is Computer name.


10. Open the sqlnet.ora file again from Notepad, and add # in front of all TCP lines.

        clipboard_ecc7be6e2e1a28819e7430f73910e639f.png 

        clipboard_eaefa23eb65468a4f71158183ade3b620.png

11. Both services (Oracle Service and TNSListener) should be set to automatic.

12. Restart the workstation.

ADDITIONAL INFORMATION

 

Not able to find a solution? Click here to request help.