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Empower client login error - ORA-12170 - WKB251530

Article number: 251530

SYMPTOMS

  • Empower client login error - ORA-12170 

ENVIRONMENT

  • Empower 3 Enterprise
  • Azure Cloud RDS Empower Application server communication with Azure Cloud Empower database server

CAUSE

This is an Oracle connection timeout that occurs when logging in to Empower from a client because it cannot communicate with the Oracle database server. 

FIX or WORKAROUND

Port 1521, which is used to connect a client to the Empower database server, is being blocked. (In some cases, Azure's NSG (network security group) rules may be blocking the connection, not Windows firewall or antivirus software.)

ADDITIONAL INFORMATION

ORA-12170: TNS:Connect timeout occurred. Cause: The client failed to establish a connection and complete authentication in the time specified by the SQLNET

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