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Copy and paste from clipboard is not working when using RDP to a Citrix server - WKB227656

Article number: 227656

SYMPTOMS

  • Local clipboard copy/paste works
  • Cannot copy remotely from the clipboard

ENVIRONMENT

  • Empower
  • Citrix server
  • RDP connection to Citrix server

CAUSE

This is not caused by Empower. Raised as CRI-3480 (likely requires a Citrix fix in a future CU).

https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/1912-ltsr/policies/reference/ica-policy-settings/bidirectional-content-redirection.html

 

FIX or WORKAROUND

  1. Use a Citrix-published Notepad as an intermediary.

  • Copy from Empower and paste to the published Notepad app.

  • Copy from published Notepad app and paste to the local machine.

ADDITIONAL INFORMATION

RDP is not tested with Empower. The following may also help with the issue:

  • Add the user or users to a remote desktop users group.

  • Check "Remote desktop connection" local devices and resources settings on all Citrix servers and Citrix clients. Clipboard and drives should be enabled.

  • Check the Local Group Policy Editor on all Citrix servers. Navigate to:

Computer Configuration \ Administrative Templates \ Windows Components \ Remote Desktop Services \ Remote Desktop Session Hosts \ Device and Resource Redirection \ Do not allow clipboard redirection

Confirm it is set to = Disabled

This issue is documented in many forums. A suggested workaround:

  1. Kill the process rdpclip.exe using the task manager in the remote computer and on the Citrix client (or the computer initiating the RDP connection).
  2. Go to RUN command and start the application rdpclip.exe.

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