Skip to main content
Waters

Waters Agilent ICF support version 3.5 fails to install. - WKB206994

Article number: 206994

SYMPTOMS

  • Install/upgrade to Waters Agilent ICF3.5 fails to install Agilent ICF

ICF_Issue.jpg clipboard_edafdfc7fb025a1878d64fd32ff21758e.png

ENVIRONMENT

  • Waters Agilent ICFv3.5
  • Waters Agilent ICFv3.5.1

CAUSE

The installer requires to make a registry key called Program1 but this was already present and in use.

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Waters\Empower\Toolkit\CustomPrograms\ConfigurationManager

This is the key and value which the installer needs to create:

Program1 - "Agilent PreConfiguration" C:\Empower\Instruments\AgilentLC\PreConfigClient.exe

clipboard_e768d2edc14e31023fb1548c96796cf39.png

FIX or WORKAROUND

  1. Delete the existing Program1 key.
  2. Run the Waters Agilent ICFv3.5 install/upgrade again.

ADDITIONAL INFORMATION

In this case it was a Citrix environment but it will happen in any environment where the registry key Program1 is already in use.

NOTE: If CTC Pal drivers are installed they may not allow the Program 1 key to be created. Remove the CTC Pal drivers before attempting to install/upgrade ICF3.5 or 3.5.1.

id206994,

Not able to find a solution? Click here to request help.