With Agilent 7890 or 8890 GC and HS7697A, Empower error message "Unable to perform the operation because the system is in monitor mode" - WKB192063
SYMPTOMS
Three error messages appear in order as follows:
- "Unable to perform the operation because the system is in monitor mode"
- "Fatal: The connection to an analysis signal was lost during the run, so the sequence was aborted."
- This message may occur either before starting a sample set or during an ongoing acquisition, potentially resulting in an instrument failure. (ICF SL 3.6 and above)
ENVIRONMENT
- Empower 3 Enterprise
- Agilent Instrument Control Framework v3.3 and v3.5 and above
CAUSE
The communication between the GC, HS, and the LACE or Acquisition Client must be robust. Any loss of communication packets from the Agilent GC or HS side may cause this behavior.
When packet loss occurs, the GC or HS may temporarily lose communication for as little as two seconds and then attempt to reestablish it. This brief interruption can cause the operating system to assign a new communication port and a new channel subscription port by the Agilent driver to the process. The newly assigned port will attempt to communicate but fail because the previous connection, tied to the old process ID, is still active.
This scenario also results in the GC or HS instrument entering "Monitor" mode.
FIX or WORKAROUND
-
If the ICF SL version is between 3.3 and 3.5.1:
- Ensure a sequential reboot has been performed between the Agilent GC, HS, and LACE/Acquisition clients.
- Follow these steps in order:
- Turn OFF the GC and HS using the instrument power switch.
- Reboot the LACE/Acquisition client and wait until the reboot is complete. Log in to the PC.
- Turn ON the GC, followed by the HS.
-
If the ICF SL version is 3.6 or higher:
- Navigate to Run Samples > Agilent GC Control Panel.
- Go to the Module Options tab.
- You should see two buttons available: "Initialize" and "Terminate".
- Perform the following steps:
- Click Terminate and wait for at least 30 seconds.
- Click Initialize to establish communication with the new process ID.
ADDITIONAL INFORMATION
-
If the instrument is connected via an Instrument LAN bridge:
- It is recommended to remove the bridge.
-
For robust communication between the Agilent GC/HS and LACE/Acquisition client:
- Use an external switch for communication.
- Ensure that Cat5e or Cat6 cables are used for the connection.
Created the CRI-8550 and investigating this issue along with Agilent.
